It is retarded. Why do people insist on writing:
boolean overwrite = check();
if (overwrite == true) {
doSomething();
}
when this does the same, requires less typing and is more natural to read:
boolean overwrite = check();
if (overwrite) {
doSomething();
}
Oi!